Dark Lantern

View previous topic View next topic Go down

Dark Lantern

Post  Aarkon on Wed Aug 24, 2011 10:12 pm

on the crippling strike access do you mean you need 8 rogue levels? 4d6 sneak to qualify? ..if so why is its own sneak dice not allowed for this?

Aarkon

Posts : 21
Join date : 2011-06-17

View user profile

Back to top Go down

Re: Dark Lantern

Post  Kaedrin on Wed Aug 24, 2011 10:17 pm

It means exactly what it says. 4d6 sneak attack.

It's own sneak dice ARE allowed. Don't make up stuff that indicates it isn't.

Kaedrin
Admin

Posts : 352
Join date : 2011-04-15
Age : 42

View user profile http://nwn2customcontent.forumotion.com

Back to top Go down

Re: Dark Lantern

Post  Aarkon on Thu Aug 25, 2011 1:12 am

im not i was asking .. you know you are very deffensive i have a DL toon that has 4d6 sneak from varios sources and it couldent take crippling strike dread commando and DL totaling 5d6 sneak atm the crippling strike was not in the list of feat choices ( on a DL feat level )

Aarkon

Posts : 21
Join date : 2011-06-17

View user profile

Back to top Go down

Re: Dark Lantern

Post  Kaedrin on Thu Aug 25, 2011 1:55 am

You posted misinformation as fact. It's own sneak dice DO count and your post implied otherwise. Every single time someone posts stuff like that and I don't correct it, I get emails/posts about it later that 'something is broke because I read X here so it must be true' which really pisses me off. That's why I ask people NOT to guess on why something isn't working. Just give me as much detail as possible and let ME look into it.

Fact: Dark Lantern sneak dice DO qualify for crippling strike.
Fact: Stacking code for sneak dice is done AFTER you level up and not in the middle of it. That's why you don't see "4d6" sneak during level up but you 'suddenly' see it on your character sheet after you level up.
Fact: Feat prereqs have to be met WHILE leveling up. So if you had 4d6 sneak BEFORE you started to level up as a dark lantern the crippling strike feat would be available to you. If you were expecting the stacking code to give you 4d6 in the middle then that is why it's not working.

I tested a Bard 7 -> DreadCom 5 -> Dark Lantern 3 and at 15th I had the option to take crippling strike. Because at 14th I had 4d6 sneak dice that were required for the level up process. So I know for a fact it works.

So here is my suggestion: Next time say something like "I can't seem to get access to crippling strike and I have X levels of Y class, A levels of B class, and on my Z'th level up as a C I couldn't take crippling strike." That's the perfect and specific info I would need to point out any such issue as needing to have the dice stacked *before* leveling up. Not having to deal with a post about a classes own sneak dice not working for it or that you somehow require 8 levels of a class that has nothing to do with it. Those kinds of posts are damaging to the community and irritating as frell to me because I have to do damage control. Thus the 'defensive' attitude.

Kaedrin
Admin

Posts : 352
Join date : 2011-04-15
Age : 42

View user profile http://nwn2customcontent.forumotion.com

Back to top Go down

Re: Dark Lantern

Post  Aarkon on Thu Aug 25, 2011 8:02 am

did you not see where i said i had >>5d6<< sneak BEFORE taking my 18th level and crippling strike was NOT on the feat list?

my build has 6 fighter, 4 dread commando, and 7 Dark Lantern and on levle 18 taking my 8th DL level crippling strike was not there as a choice

the only thing i can think of is if the access to that feat was put in the latest update 1.42? and not allowed on previous versions as LoA has yet to update to 1.42

as far as me stating things as facts i did no such thing my first post was all questions hence the "?'s" if some guy reads that as gospel from some random guy how is it my fault? no need to get mad at me bro all im trying to do is HELP you get all the kinks out

Aarkon

Posts : 21
Join date : 2011-06-17

View user profile

Back to top Go down

Re: Dark Lantern

Post  Kaedrin on Thu Aug 25, 2011 10:36 am

Are you sure LoA has 1.41.4? The change was part of that update, not 1.42.



I tested what I released for 1.41.4 and it worked. If it doesn't work on LoA and you are sure they updated to 1.41.4 then talk to the devs there about the problem.

Kaedrin
Admin

Posts : 352
Join date : 2011-04-15
Age : 42

View user profile http://nwn2customcontent.forumotion.com

Back to top Go down

Re: Dark Lantern

Post  Kaedrin on Thu Aug 25, 2011 11:38 am

No need to answer, I talked with Adam of LoA and until 10:30cst this morning LoA was not running 1.41.4.

You were reporting bugs based on playing on a server that didn't have the content with the changes.

Kaedrin
Admin

Posts : 352
Join date : 2011-04-15
Age : 42

View user profile http://nwn2customcontent.forumotion.com

Back to top Go down

Re: Dark Lantern

Post  Aarkon on Thu Aug 25, 2011 4:22 pm

yeah lol goofyness ensues

Aarkon

Posts : 21
Join date : 2011-06-17

View user profile

Back to top Go down

Re: Dark Lantern

Post  Aarkon on Fri Aug 26, 2011 11:16 am

ok were up to current release and i still cant take crippling strike same build

at lvl 17 .. 6 ftr 4 dread 7 DL taking my 8th level of DL and the feat is not in the list

now the only thing i can think of is that the toon was created on a prior version and is somehow bugged so id have to remake it

do you think this is the problem?

Aarkon

Posts : 21
Join date : 2011-06-17

View user profile

Back to top Go down

Re: Dark Lantern

Post  Kaedrin on Fri Aug 26, 2011 1:40 pm

Ask them if they made that change. I've confirmed it works just fine in mine so it's a server specific issue as far as I know.

Kaedrin
Admin

Posts : 352
Join date : 2011-04-15
Age : 42

View user profile http://nwn2customcontent.forumotion.com

Back to top Go down

Re: Dark Lantern

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum